WordPress Gutenberg 10.2 Végzetes hibák okozása

Avatar admin | 2021.03.20. 20 Views 0 Likes 0 Ratings

20 Views 0 Ratings Rate it

A WordPress kiadói felfedezik, hogy a Gutenberg 10.2 (kiadva 2021. március 17-én) „végzetes hibákat” okoz a WordPress inkompatibilitási problémája miatt. Az egyik kiadó azt javasolta, hogy a Gutenberg automatikus frissítése végezzen kompatibilitási ellenőrzést, és figyelmeztetést indítson, ha az összeférhetetlenség fennáll.

WordPress Gutenberg

A Gutenberg egy vizuális WordPress webhely-szerkesztő, amely gyökeres eltérést jelent a weboldalak natív felépítésétől a WordPress magjában.

Lehetővé teszi a megjelenítők számára, hogy blokkok grafikus felhasználói felülete segítségével webhelyeket hozzanak létre. Például egy weblap blokkként jeleníthető meg, amelyek az oldal tetejét (fejlécet), a tartalmi területet, az oldalsávot stb. Képviselik.

Hirdetés

Olvassa tovább az alábbiakban

Gutenberg még nem fejeződött be, a teljes webhely-szerkesztési lehetőség még mindig készen áll. Tehát természetesen egy még nem kiforrott technológiai hibára számítani kell, ha nem is várható.

Gutenberg 10.2 Végzetes hiba

Az Advanced WordPress Facebook csoport egyik tagja megbeszélést indított a Gutenberg 10.2-re történő frissítés során felmerülő végzetes hiba dokumentálása érdekében.

A bejegyzés szerint a végzetes hiba a WordPress 5.6 verziójában nyilvánult meg. Megjegyezték azt is, hogy a hibáról szóló GitHub-bejegyzés megjegyezte, hogy a Gutenberg 10.2 sem kompatibilis a WP 5.5-tel.

A WordPress és a Gutenberg kiadási idővonal

A WordPress 5.7 2021. március 9-én jelent meg.

A Gutenberg 10.2 webhelyszerkesztő valamivel több mint egy héttel később, 2021. március 17-én jelent meg.

A Gutenberg webhelykiadóknak, akik frissítettek a WordPress 5.7-re, majd a Gutenberg 10.2-re, nem szabad ezt a hibát látniuk.

Hirdetés

Olvassa tovább az alábbiakban

Azok a kiadók azonban, akik frissítettek a Gutenberg 10.2-re, de nem a WordPress, tapasztalhatják a végzetes hibát.

A végzetes hiba különösen hajlamos azokra a kiadókra történni, akik Gutenberg telepítéseiket automatikusan frissítik (automatikus frissítéssel), de nincsenek beállítva a WordPress automatikus frissítésére.

A tisztviselőnél hibát észleltek Gutenberg WordPress támogató fórumok de az írás idején nem volt nyomon követés.

A végzetes hibakérdést a tisztviselő is dokumentálta Gutenberg GitHub oldal.

A GitHub jelentésből:

„Miután frissítettem a 10.2.0-ra, kaptam egy e-mailt a plugin technikai problémájáról:

E_ERROR típusú hibát okoztak a fájl 59. sorában … Az ftp-n keresztül sikerült kikapcsolnom a bővítményt. Most nem akarom aktiválni, amíg nem tudom, hogy ezzel foglalkoztak.

Egy másik személy közzétette, hogy észrevették ugyanezt, és közzétett egy képernyőképet:

WordPress Gutenberg végzetes hibaPillanatkép a WordPress Gutenberg halálos hibájáról

A képernyőképet közzétevő felhasználó a következőket követte:

„A WordPress 5.6-ot futtattam. Az 5.7-re történő frissítés után minden a várt módon működött. ”

Az a személy, aki kezdeményezte az eredeti GitHub-bejegyzést, megerősítette, hogy ez az ő kérdésük is.

Hirdetés

Olvassa tovább az alábbiakban

„Köszönöm, hogy értesítettél az 5.7-ről. A WP-t sem frissítettem, most újra aktiválhatom Gutenberget.

Gutenberg 10.2 Nem kompatibilis a WordPress régebbi verzióival

Egy másik GitHub Gutenberg-jelentés kiemelte, hogy a Gutenberg 10.2 halálos hibákat okozott a WordPress régebbi verzióiban.

A WordPress 5.5.3 verzióját használó kiadó végzetes hibáról is beszámolt, amely összeomlást okozott.

A problémát bejelentő személy megerősítette, hogy a Gutenberg 10.2-re jellemző, és kijelentette:

„Deaktiváltam a Gutenberg plugint 10.2.0. Amikor megpróbáltam újraaktiválni a bővítményt, a végzetes hiba visszatért.

Fatal error: Uncaught Error: Class 'WP_Block_Supports' not found in..."

A személy hasznos észrevételt tett és javaslatot tett arra, hogy a Gutenberg 10.2-et ne engedjék frissíteni (vagy automatikusan frissíteni) a WordPress WP 5.7-nél kisebb verzióin.

„Nem kellene lehetővé tenni a Gutenberg beépülő modul automatikus frissítését egy régebbi WP webhelyen. Mivel úgy tűnik, hogy az eredmény végzetes hibát okoz. Mivel nagyon sok webhely találkozhat ezzel a problémával. ”

Hirdetés

Olvassa tovább az alábbiakban

Ez jó megoldás a problémára! Ha ismert összeférhetetlenség létezik a Gutenberg 10.2 és a WordPress régebbi verziói között, akkor van értelme, hogy az automatikus frissítés ezekben a helyzetekben leáll, és figyelmeztetést generál az összeférhetetlenségre.

A Gutenberg webhelyszerkesztő felhasználói, akik a WordPress WP 5.7-nél régebbi verziójával publikálnak, megfontoltnak tarthatják a legújabb verzióra történő frissítést, mielőtt frissítenének a Gutenberg 10.2-re.

Idézetek

GitHub:
A Gutenberg 10.2.0 zárolása végzetes hibát okozott # 29977

GitHub:
Végzetes hiba a Gutenberg plugin 10.2.0 # 29972-ben

Facebook: Haladó WordPress Group (a tagsághoz csoporttagság szükséges)
Az FYI, a legújabb Gutenberg plugin 10.2 frissítés végzetes hibát okoz




Source link


20 Views 0 Ratings Rate it

  • Minden jog fenntartva 2019-2020. Hogyankészítsek.Hu Impresszum Adatkezelési szabályok